Fandom

武装突袭 Wiki

ArmA 2 Terrain Tutorial

简体 | 繁體

4,827个页面创建
于此维基上
添加新页面
评论0 Share

您使用了广告屏蔽软件!


Wikia通过广告运营为用户提供免费的服务。我们对用户通过嵌入广告屏蔽软件访问网站进行了使用调整。

如果您使用了广告屏蔽软件,将无法使用我们的服务。请您移除广告屏蔽软件,以确保页面正常加载。


Introduction 编辑

File:Terraintutoverview.jpg

This simple learning by doing tutorial will explain the basic process of creating an island for ArmA 2, Operation Arrowhead or Combined Operations.

What the tutorial will deal with:

  1. Setup Editing Tools 2
  2. Preparing the Working folder
  3. Setup Visitor & The Landscape
  4. Binarizing your world properly.
  5. Adding Objects
  6. Add more Surfaces


Relevant sources about terrain creation 编辑

Installation of the BI Editing Tools 2 编辑

It is very important to choose a proper place to install the BI Editing Tools 2 before starting with anything else.
A clean, empty partition is highly recommended (see how to create a partition).

In this tutorial we will use the partition: O:\.
  • 1: Download the BI Editing Tools 2 first.
  • 2: Next create a folder called BIS TOOLS 2 in your designated partition. In our example: O:\BIS TOOLS 2\.
  • 3: Open or extract the downloaded zip file and start the BI_Editing_Tools_2_Setup.exe.
  • 4: The installer is basically self explanatory.
    Make sure to change the directory for each tool from the default location to your desired folder.
In our example: O:\BIS TOOLS 2\.

File:Tutorial tool install 1.jpg

Make sure to define the respective path for each tool. E.g.: 
O:\BIS TOOLS 2\Oxygen 2
O:\BIS TOOLS 2\Visitor 3 
.. and so on.
  • 5: All tools should be installed now in respective directory (O:\BIS TOOLS 2\).
    Every Tool is stored in its own folder:

File:Tutorial tool install 2.jpg


Video Tutorial 编辑

You can watch the installation process in this Video Tutorial : Setup Editing Tools 2.

The mysterious P: drive 编辑

A new partition called P: will be automatically created during the setup. An ArmAWork folder will be created in your my documents folder as well.

..\my documents\ArmAWork

Understand that the P: drive the ArmAWork folder are the same. They are just different views on the same folder.

You can read more about the tools drive here.

Note that the name tools drive is very misleading. It is your editing workspace (virtual) drive.

The P: drive has two main tasks:

  1. Your personal workspace. So the place where you files will reside.
  2. Extracted source files from BI or other sources you want to use in your terrain.

More details below.

Note that P: Drive already contains the ca folder. ca is the project space from BI.

Never ever put your files into p:\ca\*.

In this folder we will extract the source of the BI files currently still in the PBO as part of the game folder. Right now the ca folder contains a couple of unpacked pbo files already and another folder called Roads2.

We will ignore these for now.

Extract BI addons to P: 编辑

  • 1: Go to P:\CA\ and create a new folder called plants2.
  • 2: Browse to your ArmA2 main directory/Addons folder and unpack the plants2_bush, plants2_clutter, plants2_misc, plants2_tree .pbo's
    • How to Extract Pbo files?
    • Download the latest Versions of ExtractPbo and DePbo by Mikero at DevHeaven
    • Extract them right into our Tutorial partition O:\ComTools\ExtractPbo.....(xp home users extract tools to a manual folder called Com Tools in the P partition.)
    • Move the DePbo.dll from the downloaded DePbo into the ..Windows\System32 folder (as explained in the readme.DePbo.txt)
    • Rightclick on a *.pbo and choose Open with, then point to the ExtractPbo\ExtractPbo.exe and mark the checkbox to always open this filetype with ExtractPbo.exe.
    • Now each time you unpack a *.pbo by doubleclick you'll receive a clean unpacked file with *.p3ds, config.cpp and all other stuff from the pbo.
    • There are of course much further ways to extract pbos and unrap config.bin's but this is a very conformable one.
  • 3: Rename this extracted folders by removing "plants2_" of the name.
  • 4: Cut&Paste the bush, clutter, misc and tree folders to the new created P:\CA\plants2\ folder.
  • 5: Now extract building2.pbo, and place the output in the same directory as plants2. This time you don't need to rename anything.
  • 6: Now extract the Ca.pbo but only Cut&Paste the stuff inside the extracted Ca.pbo to P:\CA\
    • You can do this with all other pbos but for this tutorial we are only using building2&plants2.
  • 7: When it´s done so your P:\CA\ should look as shown in the picture below. (XP home users convert all Chernarus content have folder/subfolders same name , .cpp file down in tut.)

File:Tutorial tool install 3.jpg

Create Your Project folder 编辑

The project folder is your workspace - the place you can go crazy inside and have all your files in.

First register your personal tag at OFPEC. Read more about tags at OFPEC. In short a tag is to avoid name conflicts.

This tutorial will use as the tag TUT. Make sure to use your own tag registered at OFPEC.

With our new shiny tag, we create a namespace in the P:\ drive. In other words a subfolder. So go create it now.

For this tutorial it is: P:\TUT\.

Let us make the meaning of the project folder clear - The project folder is for all your various future projects. So for the individual projects we will soon create subfolders inside our project folder.

How to get working animations/ladders 编辑

Up next is the important part to make sure that we have working animations/ladders on our world.

For that we need the respective config files from each object which we are about to use within our world.

 ! NOTE: You need all BI addons correctly extracted to P:\ca to get this working.

To do that we can easy create a small bat or use the windows command line:

Command line 编辑

  1. Press the windows start button in the lower left.
  2. Select run.
  3. Write cmd and press enter.
  4. Write cd /D p:\ca and press enter.
  5. Run the following command: xcopy *.cpp P:\<YourNamespace>\ca\ /S /Y.
 ! NOTE: Adjust <YourNamespace> with your project folder name. The tutorial uses tut.

It will then copy all configs to your project folder with the correct folder structure.

Batch file 编辑

  1. Download copy_cpp.bat.
  2. Put it in your P:\CA\ folder.
  3. Run it.
  4. Copy the ca folder from p:\tut to your own project folder.

Source of copy_cpp.bat:

xcopy *.cpp P:\TUT\ca\ /S /Y


Improved version to be able to run the batch from any location:

cd /D p:\ca
xcopy *.cpp P:\TUT\ca\ /S /Y

Visitor 3 编辑

Configure Visitor 3 编辑

  • 1: Download the Tutorial Sample Map.
  • 2: Extract it to our P:\TUT\ folder - so it will look like P:\TUT\TUT_SampleMap.
  • 3: Run the O:\BI TOOLS 2\Visitor 3\Visitor3.exe.
  • 4: Also make a desktop shortcut to the Visitor3.exe (right mouse button -> send to -> desktop).
  • 5: Open Tools -> SystemPreferences and check if all paths are correct.
  • 6: You may wish to use -exthreads=0 setting in the command to launch buldozer as this dramatically reduces buldozer launch times when using the arma2oa.exe v1.55 and above.

File:Tutorial tool install 4.jpg

Update buldozer 编辑

TODO

Hint: If you are using arma2.exe from your present game version then you need to replace the bin folder in p:/ with the extracted bin.pbo from your present game version too, otherwise there is a mismatch of shaders.

Start with your new Visitor 3 project 编辑

  • 1: Open Project -> New (or press Ctrl+N).
  • 2: In the next Project parameters window select the values for:
    • Terrain grid size 512x512
    • Terrain cell size 10

File:Tutorial tool install 5.jpg

You find detailed information about the Project Parameters in the Visitor 3 Manual.
  • 3: Go to Tools -> Project parameters.
  • 4: Open the Calculator.
  • 5: Set Image Size (Pixels): 5120.
  • 6. Hit apply and close only the calculator.

File:Tutorial tool install 6.jpg

  • 7: Open Tools -> ProjectPreferences.
  • 8: Enter the path to your data folder (textures), like: P:\TUT\TUT_SampleMap\Data\.
  • 9: Click ok and close.

File:Tutorial tool install 8.jpg

  • 10: In the Project parameters window click on Base (active) and press the Edit button.
  • 11: Choose 40x40m texture size.
  • 12: Apply and close the Project parameters window.

File:Tutorial tool install 7.jpg

Import the terrain data 编辑

  • 1: Go to Open -> Import Terrain from Picture.
  • 2: Browse to P:\TUT\TUT_SampleMap\Source\terrain\terrain.pbl.
Be sure you set the view to elevation color style (hit the 5th button from the left) to see the contours. 

File:Vis b Filter.JPG

Save after each step 编辑

  • Goto Poject -> SaveAs and save your map as TUT_SampleMap.pew.
Add .pew to your filename. Otherwise Visitor 3 will not recognize the file in the future.

Import Satellite & Mask 编辑

  • 1: Go to Tools -> Import Satellite + Mask.. and browse to P:\TUT\TUT_SampleMap\Source\layer.cfg.
  • 2: Select text mode for saving the rvmats in the next window.
  • 3: Visitor asks now for the SAT file, so browse to P:\TUT\TUT_SampleMap\Source\sat_lco.png.
  • 4: Same with the Mask - point it to P:\TUT\TUT_SampleMap\Source\mask_lco.png.
  • 5: The import process begins right after you hit OK.
  • 6: That may take some minutes and Visitor might not respond until process has finally completed.
  • 7: Point the mouse somewhere in the middle of the map and hit the center mousebutton (wheel).
  • 8: A white square appears right at this position (point of view).
  • 7: Start Buldozer via Project -> Connect to Buldozer (or hit the ! icon in the top bar).
  • 8: Buldozer will now automatically convert the textures from png to paa (shown in the command line window).
  • 9: After the conversion process has finished you should be able to see the landscape in buldozer.
  • 10: The textures will appear so more you zoom onto the surface.
  • 11: Switch back to Visitor by hit Alt+Tab (don't close buldozer).
  • 12: Go to Project -> Export World.
  • 13: Save your world as P:\TUT\TUT_SampleMap\TUT_SampleMap.wrp.

Binarizing your world 编辑

  • 1: Start BinPbo O:\BIS TOOLS 2\BinPBO Personal Edition\BinPBO.exe.
  • 2: Choose the P:\TUT\TUT_SampleMap in the addon/source directory field.
  • 3: Now go to your ArmA2 Main folder and create a new folder called @TUT. Open this one and create another one which is called Addons (F:\Games\ArmA 2\@TUT\Addons).
  • 4: Back in BinPbo we set F:\Games\ArmA 2\@TUT\Addons as destination directory.
  • 5: Open the BinPbo options and remove *.wrp out of the list of files to copy directly
  • 6: In the path of temporary folder we set P:\BIN_TEMP
  • 7: Now remove the hook from use source path and enter p:\tut\
  • 8: We are ready to binarize our Island. Close the options tab and click on Pack. That may take a while, wait until Ready appears at the bottom of BinPBO.
    • if an error occurs, so buldozer will store the rpt logfile in C/user/Name/AppData/Local/Buldozer viewer.
  • 9: After BinPbo has finished you should see in your F:\Games\ArmA 2\@TUT\Addons\ folder the tut_samplemap.pbo and the logfile.
  • 10: Add the @TUT Mod folder to your ArmA2.exe shortcut ("F:\Games\ArmA 2\arma2.exe" -mod=@TUT -window -nosplash) or use one of the meanwhile available ArmA2 launchers.
  • Check out your map Ingame :-)

Objects and various Tips 编辑

Terrain editing 编辑

  • U will raise the height of a vertex slightly.
  • I will raise the height of the vertex greatly.
  • J will lower the height of a vertex slightly.
  • K will lower the height of a vertex greatly.

About vertices 编辑

You may have to hit F or G (i forget which one) to show the arrow that goes to each center point of a vertex. While moving the mouse around the map, you'll notice that the arrow cursor 'sticks' to the closest center point of a vertex.

Think of a vertex as a hexagonal shape where you simply raise or lower the center point of that shape. So, when you raise a vertex, it'll make a point upwards. Doing it repeatedly will make the point higher and 'sharper'. Therefore to make sure your terrain isn't too sharp, you'll have to raise the vertices around it as well.

Keep in mind also that editing vertices is pretty tedious, and it should really only be used for tweaking height.

Road networks do not act as objects, therefore you can only select, move, or budge them in Visitor 3. (thx to El Mariachi)

References 编辑

更多维基

随机维基